Publié par UnderNews Actu - Télécharger l'application Android

Plusieurs vulnérabilités critiques ont été découvertes dans l’un des plugins WordPress les plus célèbre, « All In One SEO Pack« , qui est installé sur des millions de sites Web, et représente un risque pour ces derniers.

WordPress est incontestablement le CMS le plus populaire, c’est pourquoi plus de 73 millions de sites Internet sont basés sur la solution. Mais cela n’a pas que des avantages, la preuve en est, attention si vous utilisez le fameux plugin « All in One SEO Pack » pour optimiser le référencement de votre site dans les moteurs de recherche. Si c’est le cas, vous devez appliquer de toute urgence la dernière version publiée via les mises à jour : All in One SEO Pack 2.1.6.

Il s’agit en effet d’une mise à jour de sécurité d’urgence incluant des correctifs pour deux vulnérabilités critiques permettant l’élévation des privilèges utilisateurs pouvant mener à la compromission d’un site WordPress ainsi que pour une vulnérabilité Cross Site Scripting (XSS) faille, découvertes par les chercheurs en sécurité de la société Sucuri. L’équipe de développement du plugin l’a mentionné dans le changelog sur le site officiel.

Actuellement, plus de 73 millions de sites Web sont basés sur la plateforme de publication WordPress et plus de 15 millions de sites parmi eux utilisent actuellement le plugin All in One SEO Pack, dédié à l’optimisation de la présence sur les moteurs de recherche. All in One SEO Pack est le sixième plugin le plus populaire sur le répertoire d’extension WordPress officiel, avec 18 601 015 téléchargements.

Selon Sucuri, les vulnérabilités critiques permettent à un attaquant d’ajouter et de modifier les méta-informations du site WordPress ciblé, ce qui pourrait nuire à sa présence sur les moteurs de recherche, et influencer négativement son classement.

Un utilisateur connecté en abonné ne possédant pas les droits administrateurs, pourrait ajouter ou modifier certains des paramètres utilisés par le plugin. Cela comprend le titre, la description et les balises meta de mots clés« , explique Sucuri.

ExpressVPN

Pour les pirates, rien de plus simple de chercher les sites vulnérables, étant donné que le plugin ajoute par défaut un commentaire HTML dans le code source des pages de chaque site où il est activé : <!– All in One SEO Pack 2.1.5 by Michael Torbert of Semper Fi Web Design[xxx,xxx] –>

En plus de cela, la vulnérabilité cross-site scripting signalée peut être exploitée par des pirates afin d’exécuter du code JavaScript malveillant sur le panneau de contrôle de l’administrateur.

« Cela signifie qu’un attaquant pourrait injecter un code JavaScript et déclencher des actions non souhaitées en toute transparence comme par exemple changer le mot de passe du compte administrateur ou encore créer un second compte administrateur dans le but de laisser une porte dérobée sur votre site Web« , déclare Sucuri.

Rappelons que les vulnérabilités pouvant être présentes dans les plugins WordPress sont la cause principale de la majorité des piratages de sites WordPress. Les exploits se négocient au prix fort sur le black market et ce sont l’un des principaux outils dans l’arsenal des pirates du Web. Les vulnérabilités du plugin pourraient être exploitées pour accéder à des informations sensibles, défigurer des sites Web (deface, ndlr), rediriger les visiteurs vers un site malveillant, y insérer un code malveillant afin d’infecter les visiteurs, ou encore pour effectuer des attaques DDoS massives.

Jusqu’à présent, aucune attaque d’envergure exploitant ces failles n’a été détectée à l’état sauvage, mais il est fortement recommandé aux propriétaires de sites WordPress de mettre à jour dans les plus brefs délais leur plugin All in One SEO Pack vers la dernière version (2.1.6).

Vous avez aimé cet article ? Alors partagez-le en cliquant sur les boutons ci-dessous :

Twitter Facebook Google Plus Linkedin Pinterest email
1 étoile2 étoiles3 étoiles4 étoiles5 étoiles (1 votes, note : 5,00 sur 5)
Loading...

Mots clés : , , , , , ,


Vos réactions

Ils parlent du sujet :

  1. […] a fait écho hier d’une grosse vulnérabilité pour ce plugin dans un article intitulé : WordPress – Vulnérabilités critiques pour le plugin All in One SEO Pack ! Je vous conseille vivement de le lire! C’est très instructif […]

  2. WordPress – Vulnérabilités ...

    […] UnderNews | Alertes  […]

  3. WordPress – Vulnérabilités ...

    […] Plusieurs vulnérabilités critiques ont été découvertes dans l'un des plugins WordPress les plus célèbre, "All In One SEO Pack", qui est installé sur des millions de sites Web, et représente un risque pour ces derniers.  […]





Notifiez-moi des commentaires à venir via e-mail. Vous pouvez aussi vous abonner sans commenter.